
Iddero Home Server 3
Getting started

Version: 4.7.1

20241202-02



Contents

1 Introduction 3

1.1 About this document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

1.2 Product overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2 The iddero-config configuration so�ware 5

2.1 Installation and first steps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

3 Touch panel configuration 7

3.1 The configuration process . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

3.2 Select the product model . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

3.3 Create or import group addresses . . . . . . . . . . . . . . . . . . . . . . . . . 7

3.4 Configure the visualization components . . . . . . . . . . . . . . . . . . . . . 9

3.4.1 General concepts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

3.4.2 Definition of zones . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

3.4.3 Definition of pages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

3.4.4 Configure components and link group addresses . . . . . . . . . . . . 12

3.4.5 Graphical navigation throughmaps (optional) . . . . . . . . . . . . . . 14

3.5 Save the project . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

4 Installation and commissioning 18

4.1 Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

4.2 Boot in “Install Mode” . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

4.3 Finding Iddero Home Server 3 in the network . . . . . . . . . . . . . . . . . . . 18

4.4 Commissioning . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

4.5 Firmware updates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

4.6 STATUS LED indicator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

4.7 Restoring default settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Restoring network settings to factory defaults . . . . . . . . . . . . . . . . . . 20

Restoring user settings to default values . . . . . . . . . . . . . . . . . . . . . 21

4.8 Static network configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

2



Introduction 1
1.1 About this document

This document is a quick guide to help you get started with Iddero Home Server 3. Detailed,

step-by-step instructions are provided on how to create and configure a simple installation

project, and to upload it to the touch panel.

This guide assumes basic knowledge and familiarity with KNX® technology and with the ETS®

configuration so�ware.

1.2 Product overview

Iddero Home Server 3 is a compact server for control andmonitoring of KNX installations. It

combines advanced functionality with a powerful, intuitive visualisation.

Control fromsmartphones and tablets is possible using the IdderoMobile app (available for iOS

and Android). A build-in web-based user interface also allows access from any device running a

standard web browser.

Function highlights:

• User-friendly navigation through floorplans and zones

• Up to 512 configurable pages, with up to 8 control functions per page (more than 4000

functions)

• Custom background images in all pages

• User-editable scenes

• Weekly time schedules

• Alarmmonitoring with event log

• Presence simulation with day and night schedules

• Event notifications via push, e-mail and GSM 1

• Logic functions (logic gates, comparators, timers, expressions, etc.)

• 8 independent thermostats

1 Requires DW-GSM expansion module
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• 8multi-function inputs, individually configurable as binary or temperature probe inputs

• Remote control from smartphones, tablets, and PCs

• Real-time clock (RTC) with backup battery

• Integrated KNX bus coupling unit (TP1)

• Ultra-low power consumption

1.2 Product overview 4



The iddero-config configuration

software

2

2.1 Installation and first steps

Iddero Home Server 3 can be configured using the iddero-config so�ware, which is available

free of charge fromwww.iddero.com. We recommend to always use the latest version available.

For Iddero Home Server 3, version 4.7 or later is required.

The first time you run the so�ware, it will request an activation key. In order to obtain the

activation key, please click on the link shown in the dialog box. This will open a web page with

a request form. Fill in the form and you will receive an activation key by e-mail.

Once the activation process is complete, the main application windowwill be shown.
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At the top, themainmenu is shown (File, Project, Programming, Configuration, and Help) along

with a toolbar with quick access buttons.

The main window is split in three di�erent areas:

• Project tree (A): Shows the project structure, including sections for general parameters,

zones and pages, maps, scenes, time programs, security, logic functions, andmore.

• Address tree (B): Shows group addresses for this project, including both regular group

addresses and internal group addresses.

• Parameter area (C): When an item is selected in the project or address trees, this area will

show any configurable parameters that are available for this item.

2.1 Installation and first steps 6



Touch panel configuration 3
3.1 The configuration process

This section walks through the basic configuration process in order to create a sample project

where Iddero Home Server 3 will be used to control a single lamp, through a KNX-based dimmer

actuator.

We will assume that the KNX dimmer actuator in question implements at least the following

communication objects:

• One 1-bit communication object for switching the lamp on and o� (address 1/1/1)

• One 1-byte communication object for setting the brightness value (1/1/2)

• One 1-byte communication object that holds the current brightness value (feedback)

(1/1/3)

3.2 Select the product model

The first thing you need to do is select the product model. For this, first select the “Project”

section in the project tree, then choose “Iddero Home Server 3” in the “System type” field in

the parameter area.

The selected product model determines the avaialable functionality, as well as resource limits

for certain functions. Available resources can be checked at any time in the Project > Resource

monitor menu option.

3.3 Create or import group addresses

Although it is possible to define group addresses directly in iddero-config, it is common to

initially import addresses from an existing ETS project.

You can import group addresses directly from the .knxproj files generated by ETS. For this, select

Project > Import ETS addresses (.knxproj)... in iddero-config, then select the .knxproj file.

7



Note

Make sure the selected .knxproj file is not password protected.

The so�ware will then show all group addresses found in the .knxproj file. Click on “Import” to

complete the import.

Note

If you try to import group addresses froma .knxproj file into a project that already contains

group addresses, you will be given two options: “Add new addresses to the existing

address tree” or “Discard existing addresses”.

Once the group addresses have been imported, they will be shown in the address tree.

3.3 Create or import group addresses 8



3.4 Configure the visualization components

3.4.1 General concepts

Navigation in Iddero Home Server 3 is based on the concept of “zones” and “pages”.

Zones are groups of devices (“components”) within the installation. A zone can represent a

room in a house, an o�ice, a department in a services building, or just a group of devices that

do not necessarily share a physical location.

Devices associated to each zone are in turn organized in one or more pages. Each page can

show up to eight devices. The grouping of devices in pages can be done based on arbitrary

criteria: Devices can be grouped by function, by type, by frequency of use, etc.

The following screenshot from the Iddero Mobile app shows the structure of a typical page with

six devices. The status bar at the top of the screen shows that this page belongs to the “Living

room” zone. The navigation bar at the bottom shows that the zone includes another two pages

besides the one shown.

In our sample project we will initially create one single zone with one single page, since we only

need to control one device.

In a real-world project, though, the navigation structure should be carefully planned so that

navigation is as easy and comfortable as possible for the end user.

3.4 Configure the visualization components 9



3.4.2 Definition of zones

In order to add a zone to the project, right-click on the “Zones and pages” section in the project

tree, and select “Insert zone” from the pop-upmenu.

By selecting the newly created zone (le�-click on the new zone in the project tree, or double-

click on the zone name in the table shown in the parameter area) the configurable parameters

will be shown:

• Name: A descriptive name for this zone.

• Background image: A background image for all pages in this zone.

Let’s configure the name for this zone, and set it to “Living room”.

3.4.3 Definition of pages

In order to add a page to a zone, right-click on the zone in the project tree, and select “Insert

page” from the pop-upmenu.

3.4 Configure the visualization components 10



By selecting thenewly createdpage, the configurable parameterswill be shown in theparameter

area:

• Name: A descriptive name for this page.

• Icon: The icon that will be shown for this page in the navigation bar.

• Page layout: Determines how components are arranged in the page.

• Restrict page access: Theminimum access level that is required in order to access this

page.

• Component 1 ... 8: Check these checkboxes to enable the corresponding components.

Since our page will be used for lighting control, you can just leave the default icon (a light

bulb).

There will be one single device in this page. Thus, check the “Component 1” checkbox: a

component will automatically be added beneath the current page in the project tree.

3.4 Configure the visualization components 11



3.4.4 Configure components and link group addresses

We will now configure the visual component that will be used to control the lamp from the

touch panel. As described earlier, we will actually be controlling this lamp through a KNX-based

dimmer actuator.

Select the component beneath the first page of the “Living room” zone. Set a descriptive name,

for example “Dimmable lamp 1”, and choose “Lamp control” from the “Type” combo box.

The dimmer actuator in our sample project implements a 1-byte communication object that

can be used to set the brightness (light intensity) value. This is o�en referred to as absolute

dimming. In the “Dimmer type” field, select “Absolute dimmer”.

Finally, in the “Status objects” combo box, select “1 byte” since our dimmer actuator provides a

1-byte communication object that indicates the current brightness status.

If you look at the project tree, you will see that several communication objects have automati-

cally been added under the “Dimmable lamp 1” component: One 1-bit communication object

(“Switching object”) and two 1-byte communication objects (“Brightness value” and “Lamp

status (dimming value)”).

3.4 Configure the visualization components 12



IdderoHomeServer 3will sendOnandO� telegrams to the first of these communication objects,

absolute brightness values to the second one, and will use the value of the third object in order

to update the graphical representation of the lamp’s status.

Group addresses must now be linked to communication objects. First, link group address

1/1/1 (“On/O�”) to the lamp’s Switching object. This is done through a drag & drop operation:

Click and hold the le�mouse button over the “On/O�” address node in the address tree; then,

without releasing themouse button, drag the address onto the communication object in the

project tree; finally, release the mouse button.

Repeat this operation with the Brightness value and Lamp status objects, and link themwith

group addresses 1/1/2 “Brightness (value)” and 1/1/3 “Brightness (status)”, respectively.

If you select any communication object in the project tree, the parameter area will show any

linked group addresses, along with the current configuration of the communication object’s

flags (please refer to the KNX standard for the detailed meaning of each flag).

Likewise, if you select any group address in the address tree, the parameter area will show any

linked communication objects.

3.4 Configure the visualization components 13



3.4.5 Graphical navigation through maps (optional)

In order to make it easier for the end user to navigate through available zones, you can define

image-basedmaps as well as active (touchable) areas within the map that can be linked to

zones or to other maps.

Note

Map definition is optional. If no maps are defined, the system will just present a list of

available zones to the end user.

In order to insert a newmap, right-click on the “Maps” section in the project tree and select

“Insert map” in the pop-upmenu. Then, just select the newly addedmap and the configurable

map parameters will be shown in the parameter area.

3.4 Configure the visualization components 14



Next step is to pick a background image for the map.

Background images can be created using any drawing or picture editing so�ware, or with

specialized CAD and 3D design packages.

Once you have your background image ready, click on the “Open...” button in the map con-

figuration section, and select the image file. GIF, JPEG, and PNG file formats are supported. If

the image size is larger than themaximum allowed size (1024 x 600 pixels) , the image will be

adapted (trimmed) automatically.

3.4 Configure the visualization components 15



Nowwe will define one active area on top of the image.

Right-click on themap in the project tree, and select “Insert area” from the pop-upmenu. Then,

select the newly created area in the project tree.

Assign a descriptive name for the area (for example, “Living room”). Then, in the “Target” combo

box, select the “Living room” zone. By doing this, we are specifying the zone that should be

opened when we touch this area on the map.

Now, the polygon associated to this active area must be defined. Click on the “Add points”

button, then click on the image to add the vertices for the polygon.

The “Delete points” and “Move points” buttons let you delete and move existing polygon

vertices.

Note

You can use themouse wheel to zoom in and out of themap. While zoomed in, hold down

the middle or right mouse button and drag the mouse to pan the image.

3.4 Configure the visualization components 16



3.5 Save the project

You can save the project at any time by selecting the File > Save menu option. We recommend

to do this o�en in order to avoid losing your changes.

3.5 Save the project 17



Installation and commissioning 4
4.1 Installation

Iddero Home Server 3 is a compact device suitable for 35mmDIN-rail mounting. It is typically

installed on an electrical cabinet, along with the provided 12 VDC power supply unit.

During the installation process, the following connections should bemade:

• Power supply (12 VDC). Only the provided power supply should be used.

• KNX bus

• Ethernet, to the local area network (LAN)

• RS-485 bus, if an expansion module such as the DW-GSMwill be used

4.2 Boot in “Install Mode”

In order to upload the project data to Iddero Home Server 3, you first now boot in “install mode”.

For this, press and hold the “RESET / PRG” button for a few seconds. Iddero Home Server 3 will

beep three times to acknowledge the request, and will automatically enter install mode (the

device also enters install mode automatically the first time it boots, or when no valid project

data is found).

Once the boot process completes, the device will beep twice, and the “STATUS” indicator will

turn green and start to flash.

4.3 Finding Iddero Home Server 3 in the network

Iddero Home Server 3 is preconfigured to obtain an IP address automatically using the DHCP

protocol. DHCP is supported by almost every Internet router, and should be available in most

home and o�ice networks. Thus in themajority of the cases, no additional configuration should

be needed at this stage.
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In order to find the current IP address of Iddero Home Server 3, select Programming > Search

for devices in iddero-config. A list of available devices will be shown, along with the IP address

assigned to each one, and someadditional information (serial number, firmware version, etc.)

Also, the “Mode” column shows the device’s current operating mode (“Install” for install mode,

and “User” for normal operation).

4.4 Commissioning

In order to upload the project data to Iddero Home Server 3, select Programming > Program in

iddero-config while the device is in installation mode.

The “Connect settings” dialog will pop up. Enter the IP address of the device and the installer

login and password (default values: “instalador” / “knxinstall”) and click “Accept”.

The commissioning processmay take a few seconds to complete. Donot interrupt this process

or turn o� the device. Once the process is complete, press the “RESET / PRG” button, and the

systemwill reboot with the new configuration.

4.5 Firmware updates

If you need to update the Iddero Home Server 3 firmware, you can do so from iddero-config by

selecting Programming > Update firmware.

The so�ware will first ask you to select a valid firmware update file (.bin file type). The “Connec-

tion settings” dialog will then pop up. The rest of the process is identical to the commissioning

process.

It is critical that you do not interrupt the operation or otherwise disconnect or turn o� the

device during the update process. If the firmware update process is interrupted, the device

could be le� in a locked state andmay need to be returned to factory for repair.

4.4 Commissioning 19



4.6 STATUS LED indicator

The “STATUS” LED indicator at the top of the Iddero Home Server shows the current status of

the device, according to the following table:

STATUS LED indicator Device status

O� The device is o�

Heartbeat: LED flashes briefly in

red two times per second

The device is booting

Flashing green

(150 ms green / 1 s o�)

The device is ready in install mode

Fixed color

(red / green / yellow)

The device is ready and operating normally. The actual

LED color depends on the application status; please

refer to the user manual for more information.

Slow flashing red

(1 s red / 1s o�)

A non-recoverable error occurred; operation is

interrupted.

4.7 Restoring default settings

The “DEFAULTS” button in Iddero Home Server 3 lets you restore certain settings to their default

values. This is a recessed button; use a small pointed object such as a paperclip to push it.

Restoring network settings to factory defaults

This procedure restores network settings to factory defaults (DHCP).

• (Recommended) Boot in install mode

• Press and hold the DEFAULTS button

• Press RESET / PRG briefly without releasing the DEFAULTS button.

• Iddero Home Server 3 will start to emit short warning beeps. Do not release the DEFAULTS

button yet.

• A�er five seconds, the device will emit a long beep. The network settings have been

restored to factory defaults. Changes will be take e�ect a�er rebooting.

4.6 STATUS LED indicator 20



Restoring user settings to default values

This procedure restores user settings (user interface language, time schedules, scenes, access

codes, etc.) to the values defined in the configuration project.

• Boot normally (do not boot in install mode)

• Once the device is operating normally, press and hold the DEFAULTS button

• Iddero Home Server 3 will start to emit short warning beeps. Do not release the DEFAULTS

button yet.

• A�er five seconds, the device will emit a long beep. User settings have been restored to

the values defined in the configuration project.

4.8 Static network configuration

Using DHCP for automatic IP address configuration simplifies the Iddero Home Server 3 con-

figuration and commissioning process, and is the recommended configuration for most use

cases (remote accesss through the Iddero Mobile app, or access through idderocloud using a

standard web browser).

However, IP addresses obtained over DHCP are typically dynamic, and can change over time.

This may confuse end users in certain situations (for example, for when using a standard web

browser within the same LAN, without using the idderocloud service).

If you want to ensure that the same IP address is always used, then there are two ways to

achieve this:

1. Configure the DHCP server (typically the Internet router) so that the same IP address is

always assigned to Iddero Home Server 3, for example based on its MAC address. This is

typically called “IP reservation” or “static IP allocation”.

2. Configure the Iddero Home Server manually to use a static IP address. You can do this

by entering the “Network settings” menu in the Iddero Home Server 3’s web based user

interface, disabling DHCP, and entering static network settings. However, if Iddero Home

Server 3 is installed in a network with a running DHCP service, you will still need to make

sure that the selected IP address is outside of the IP address rangemanaged by the

DHCP server.

In both cases, you will need to check or modify the configuration of your DHCP server. The

exact procedure depends on the device that is acting as a DHCP server; please refer to the

documentation supplied by the manufacturer for additional information.

4.8 Static network configuration 21



IDDERO

Av. Juan López Peñalver, 21

Parque Tecnológico de Andalucía

29590 Málaga, Spain

support@iddero.com

www.iddero.com

© 2024 INGELABS, S.L. All rights reserved.

Iddero is a registered trademark of INGELABS, S.L. KNX is a registered trademark of the

KNX Association cvba. All other product, service, and company names may be trademarks

or registered trademarks of their respective owners.

IMPORTANT: Only qualified electricians should install, service, or manipulate this

equipment. Existing regulations for the prevention of accidents must be observed, as well

as any national or local codes and regulations and standard safety precautions.

All information in this manual is provided “as is” without warranty of any kind, either

express or implied, including, but not limited to implied warranties of merchantability or
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